...
现象
现象:调用图库的时候提示:X调用图库的时候提示:X:\thsoft\pccad2018\THsPartBuilder\Database下未发现此图库,或不是该产品的图库!
原因1:您手动拷贝的图库,并非当前产品图库。
原因2:可能是安装包不完整,造成未安装上ACCESS数据库驱动引擎。该情况更为常见一些。
原因
1、您手动拷贝的图库,并非当前产品图库。
2、可能是安装包不完整,造成未安装上ACCESS数据库驱动引擎。该情况更为常见一些。
请查看安装包下是否有以下文件:…\Setup\Support\AccessDatabaseEngine_X64.exe。
没有,则可能被杀毒软件误删除了。请关闭360、杀毒软件,重新解压安装包,或重新下载,确保有该文件。
然后运行安装包…
【注】不同版本都可能有同样的情况,请找到与购买版本一致的安装包查看,下面以PCCAD V21为例说明。
没有,则可能被杀毒软件误删除了。请关闭360、杀毒软件,重新解压安装包,或重新下载,确保此目录下有该文件。
3、ODBC没有安装好
打开控制面板,搜“ODBC”,找到“设置ODBC数据源(64位)”,看是否可以正常运行。
以下是正常情况:
解决方法
一、修复安装
修复安装CAD,会自动加参数,比较傻瓜,但会覆盖用户自定义环境数据。
运行安装包…\Setup\setup.exe,修改或修复安装天河CAD即可。
(注意在文件资源管理器中点“查看”——勾选“文件扩展名”,否则无法显示出扩展名)
二、手动修复方法
手动修复安装access驱动引擎,可以保障不会覆盖用户自定义环境数据。
三、修复ODBC
如果以上方法没有解决问题,请尝试执行ODBC。
如果弹出类似以下的错误窗口,则可能您安装的是精简的操作系统(如系统之家下载的镜像系统),ODBC没有安装完全。
可尝试从正常的电脑以下的 C:\Windows\System32 下拷贝“ODBC”开头的几个dll和exe文件,替换到您电脑的相同路径下。